Service degradation in Waterford Reading Academy
Incident Report for Waterford Research Institute
Resolved
All applications are functioning normally.
Posted Dec 07, 2021 - 19:22 MST
Update
Degraded performance is improving some residual slowness and erroring may still occur. Users should be able to Authenticate and use Waterford Reading Academy student, teacher, Waterford Mentor, and Upstart applications with minimal wait time. We will continue to monitor for optimal performance and outstanding issues.
Posted Dec 07, 2021 - 15:34 MST
Update
We are continuing to work with our hosting partner to restore performance and services critical to the authentication and operation of Waterford Reading Academy student and teacher applications. Some applications have been restored and are now operational updates will continue until all have been fully restored. Ongoing work and the most up-to-date progress can also be found at https://status.aws.amazon.com/
Posted Dec 07, 2021 - 14:08 MST
Identified
Our hosting partner has identified root cause and is working toward a solution, more information about this incident and current status of our hosting partner check https://status.aws.amazon.com/.
Posted Dec 07, 2021 - 11:34 MST
Investigating
Our hosting partner is currently experiencing a service degradation affecting Waterford Reading Academy and Waterford Early Learning this has resulted in longer than usual page load times and 504 Gateway Timeout errors. We are working with our partner to address these issues and will provide additional updates as more information becomes available.
Posted Dec 07, 2021 - 10:44 MST
This incident affected: Waterford Early Learning (WEL) (Waterford Early Learning Manager, Waterford Early Learning Student Portal), Waterford Reading Academy (my.waterford.org, mentor.waterford.org, teacher.waterford.org), and Waterford Mobile Mentor, Reporting and Dashboards.