Users unable to authenticate with Waterford Reading Academy products

Incident Report for Waterford Research Institute

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 08:29 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2025 - 07:34 MDT

Identified

The issue has been identified, and a fix is currently in progress
Posted Mar 12, 2025 - 07:23 MDT

Investigating

We are currently investigating this issue.
Posted Mar 12, 2025 - 07:19 MDT
This incident affected: Waterford Reading Academy (my.waterford.org, mentor.waterford.org, teacher.waterford.org) and UPSTART (upstart.waterford.org).